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Introduction 
This manual provides guidelines for authoring NeoVision Hypersystems, Inc. technical 
publications for software products. Technical publications include: 

§ Online help for Heatmaps® and other NeoVision software products 

§ Manuals, both print and softcopy, for end-users 

§ Software developer materials for internal staff use, such as API (Application Program 
Interface) references and product specifications 

We apply guidelines to assure a consistent company look-and-feel across our product 
line. We attempt to eliminate indications that multiple persons contribute to a single 
document or help system in an ad hoc manner. Instead, our material should look as if 
one generic writer and process compiles it. The guidelines in this manual aim to also 
provide a consistent look to content. In particular, we attempt to keep the material easy 
to read, free of distracting changes from topic to topic or chapter to chapter.  

All of the guidelines in this document are open to opinion and change. Please submit 
your requests for change to the NeoVision NY Office, attention Technical Writer. 

Part I provides general guidelines that apply to any technical publication of NeoVision. 
Part II refers to online help and considers the features and limitations of the ForeHelp 
authoring tool that NeoVision currently uses to create and build help systems. 

In addition to this Style Guide, authors can refer to the following documentations for 
guidance in style application:  
§ The Chicago Manual of Style, 14th ed. Chicago: University of Chicago Press, 1993 

§ Microsoft Manual of Style for Technical Publications, 2nd. Ed. Redmond: Microsoft 
Press, 1998 

Both of the preceding references are available in the Technical Publications Dept., 
NeoVision NY office. This NeoVision Style Guide refers to these manuals as Chicago 
and Microsoft, respectively. 
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Part I: General Guidelines 
This section describes those style features that appear in all documents, without 
consideration to the tool that produces them or the manner of delivery. 

Capitalization 
This section categorizes uses for the following capitalization styles: 

§ Title style capitalizes the first letter of each significant word in the heading.  

§ Sentence style capitalizes the first letter of only the first word in a phrase. Sentence 
style capitalization does not require a complete sentence or a final period.  

§ Initial capitalization (or init-cap) uses uppercase as the first letter a word.  

Title Style 
Use title-style capitalization in headings. Start the following with an uppercase letter: 

§ The first word in the heading.  

§ Nouns 

§ Verbs 

§ Both words in a hyphenated adjective (Right-Click) 

§ Subordinating conjunctions (Because, That, If) 

Do not capitalize coordinating conjunctions (and, but, or, for) unless they appear as 
the first word in the title. (See Chicago, section 7.127 for a more exhaustive list.) 

Sentence Style 
Use sentence-style for figure captions. Example: 
Figure 1: Datafeed tab with dynamic contents 

Use sentence style for each item in a list. For more information, see the Error! 
Reference source not found. section. 

Initial Capitalization 
When describing an interface, particularly the Heatmaps Editor, use init-caps to indicate 
tab names, names in the menu bar, or a label that introduces a field. Do not capitalize 
these names in other contexts. Examples: 
Initial Capital Lowercase 

The Editor consists of a Datafeed tab, 
Database tab,…  

You can only edit cells in the viewer that the 
datafeed supplies. You cannot edit database 
values. 

To edit an existing content, select a name 
from the Content Name drop-down list. 

A datafeed content specifies the grouping and 
source data fields that appear in a single display. 

As part of the definition for the Cell Right 
Click menu on the Displays tab, specify the 
name of a cell page display  

To add a cell to the page display, right-click the 
cell and select Page Display from the cell menu. 

Group Label Formula list Enter a formula in the Cell Label field.  

Use lowercase for formula because it does 
not appear as part of the field name in the 
Connections tab.  
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Always start the following with an uppercase letter: 

§ Menu names (File menu, Edit menu) 

Do not capitalize menu. 

§ Key names (Shift, Ctrl, Enter) 

See CapitalizationKeyboard Keys and Shortcuts (page 7). 

§ Dialog names (Control Panel) 

§ Heatmaps, Heatmap, Hotspots 

§ Heatmaps Viewer and Editor 

Use the same capitalization that appears in the Editor list fields. For example, initial-
capitalize the entries from the Displays tab Type field: Grid, Mosaic. In other contexts, 
use lower case. For example: 
In the Displays tab, Type field, select Grid to create a grid graphical display. 

Use the same capitalization for field labels that appears in the Editor dialogs, even when 
the Editor dialogs do not appear consistent.  For example: 
Select a graphical display Type from the drop-down list. 

Check the sortable check box to apply order formulas from the Connections tab to this group. 

Font and Character Formatting 
Font consists of a family (Arial, Courier), style (bold, italics, underline, as well as 
color), and size (9,10, 12). Normally, the paragraph style specifies the appropriate font 
information for the style. In some cases, you override the family, style, or size to 
emphasize a term or phrase. 

In most cases, use the default paragraph style for the paragraph tag. For example, the 
NeoVision template base or normal paragraph styles default to family Arial, style regular 
with automatic color, size10 point.  

Note:  This Style Guide uses 12 point as the base default to enable the reader to 
distinguish examples, which use the recommended 10 point. 

Family Overrides 
Apply an override font family only when you need to distinguish a term or phrase in a 
paragraph the normally uses Arial.  The only valid change in family apply Courier to 
indicate computer font or a symbol font for special characters. 

Courier 
If an entire paragraph appears in a family other than Arial, use a paragraph style. For 
example, paragraph style XMP uses Courier as its default font for user entries that are a 
complete paragraph of more. Example:  

Datafeed.Primary.NAME & "(" & Datafeed.Primary &")" 
Override the default font with Courier for the following circumstances: 

§ Characters that the user types in through the keyboard. Examples: 
Use myPortfolio as the content Name. 

The butChgPd button calculates………. 

§ Selections from a list, even when provided as part of the Editor: 
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From the Type drop-down list, select Grid, Mosaic, Bar, Hotspots, or Tree. 

Notice that the commas and the word or remain in Arial. Use care in selecting the 
word without the separator when you apply the Courier font in an otherwise Arial 
block of text. 

Note: Depending on feedback from users of this Style Guide, future editions of this 
Style Guide might use a different approach to drop-down list choices, such as Arial 9 
point. (See Size section discussion about fonts used for Heatmaps buttons. . 

§ Built-in variables and functions: 
Use groupvalue as the label. 

The built-in function avg() averages the values for all the cells in the group. 

§ File names, file extensions, and paths: 
Each Heatmap file name ends in the extension .nvg. 

Style Overrides 
Style overrides: 

§ Apply emphasis 

§ Focus attention to an area of the interface 

§ Apply a common user interface standard (typically to a link) 

§ Enable reverse text on a color background 

Overrides enhance, rather than detract from, clarity and usability. Apply them only when 
necessary to distinguish some portion of text from the block that contains it.  

Italics 
Override the default paragraph font with italics in the following circumstances: 

§ If you introduce a new term  

Use italics only for the first occurrence of the term in the topic where you introduce it. 

§ Title of a book or other cited reference  

§ Placeholders for unknown (variable) information 

Do not enclose formula variables in angle brackets (< >), which have special 
significance in tagging languages, such as XML and HTML. 

Correct: Open the heatmapname.nvg file. 

Incorrect: Open the <heatmapname>.nvg file. 

Use italics sparingly.  

Bold 
If an entire paragraph appears in a font style other than regular, use a paragraph style. 
Caption style defaults to bold, Paragraphs with style names such as header, head, or (in 
HTML) H default to bold and larger point sizes.  
Override the default paragraph font with bold in the following circumstances: 

§ In a procedure (only), bold the name of an Editor field. Example: 
1. Click the Datafeed tab. 
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2. Enter a unique character string in the Content Name field. Start contents names with the 
characters cnt. 

Notice that contents in the above example is lower case and regular font weight (not 
bold), as only the singular form, Content appears on the Datafeed tab. Notice that the 
second occurrence of names is lower case and not bold, as that instance refers 
generically to possible contents name strings. 

In the following example, the field name is not bold because the sentence does not 
occur as a numbered step in a procedure:  
In Figure 2, the contents Name field contains the unique string cntMyPortfolio 

§ Editor and Viewer dialog button names and menu bar item names, in a procedure. 
Example: 
1 Select Tools > Control Panel…. 

2 After you change the variable value in the Control Panel, click Apply. 

Notice in this example, the Control Panel appears bold only in step 1, where you select 
it as a menu option. 

Also notice that the ellipses (…) that indicate dialog are also bold. 

Use bold sparingly. Do not use bold to emphasize a word or phrase, except when to do 
so adds clarity, as in the following example: 
An Editor tab might identify a label formula field with the word Label: or the phrase Label 
Formula:.   

Do not use bold for keyboard key names. See Keyboard Keys and ShortcutsKeyboard 
Keys and Shortcuts. 

Underline and Color 
Do not use underline for any purpose other than to indicate a hyperlink. Allow the 
authoring tool to apply its default font style for hyperlinks when you select a term as a 
link. For example, web-authoring tools generally apply blue underline to a link. 

Do not underline a shortcut key in a menu option. See Keyboard Keys and Shortcuts 
(page 7). 

If you use a background color, for example in a table, then print the text in white. The 
following shows an example of the TableHeadRow paragraph style and the from the 
online help template: 

Column One Column Two 

Size 
In most cases, use 10 point  for online information because the user browses through 
the material in a monitor window which has limited space for text.  

Exception: User-defined cell and group labels, as well as user-defined button names in 
the Heatmaps Viewer. For Viewer labels (unlike Editor labels), always use font style Bold 
Name, which reduces the font by one point and applies bold.   

Keyboard Keys and Shortcuts 
Microsoft uses all uppercase for key names. NeoVision, in contrast, uses initial 
capitalization.  Do not apply a bold font override to key names. Use the default 
paragraph font for the key name. NeoVision does follow the Microsoft use of the plus 
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sign (+) to combine keys that the user presses together. Use key names as nouns, not 
adjectives. Do not follow with the word key. 
Press Alt+f to open the File menu.  

Do not underline shortcut keys in menu names: 

Correct: Select File > Open. 
Incorrect: Select File > Open 
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Captions and Headings 
Always use the appropriate style name from the NeoVision template for the authoring 
tool. Never use a base or normal paragraph style with a bold override as a heading or 
caption.  

Captions 
Caption style defaults to Arial, 10 point, bold. You can override individual words 
according to the rules for Courier (page 5). 

Always prefix a caption with a Figure number. If the authoring tool provides automatic 
caption numbering, use it to keep the caption sequencing correct as you insert or delete 
figures. For example, in Microsoft Word, use Insert > Caption.  

Every figure must have a caption, even if only one figure appears in a (help) topic or 
(book) chapter. Placement of captions depends on the delivery format. Any figure that 
appears in an online document, whether online help, HTML document, or electronic 
version (PDF) of a book, should have figures above or alongside of the figure so that the 
user need not scroll to see the figure number. 

Use captions as cross-references or links so that the reader can return to the figure 
easily.  

§ In ForeHelp, you must create both target and link. Highlight the caption and apply 
Hotspot > Insert mid-topic target then use Insert Jump to create the link. 

§ Microsoft Word automatically recognizes captions as targets. Use Insert > Cross-
reference > Figure (or Table for a captioned table) to create the link. 

§ In HTML, enclose the caption in <a name=”targetID”> </a> to mark the target. 
Enclose the link with <a href=”targetID> </a>. 

Headings 
Paragraphs with style names such as heading, head, or (in HTML) H default to bold and 
larger point sizes.  

§ HTML uses <H1>, <H2>, and so forth for hierarchical heading paragraphs.  

§ Microsoft Word uses Heading 1, Heading 2, through Heading 9.  

§ The NeoVision template for ForeHelp uses the HTML convention H2, H3. There is no 
H1, which is reserved for the ForeHelp convention of Banner style.  

Do not confuse heading style with header style, which applies to the running head in the 
top margin of each page. 

Create sequential hierarchies of headings. 

Correct 
H1 

   H2 

   H2  

H1 

Incorrect: 
H1 

      H3 

   H2 
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Try to restrict headings to 3 levels. Because we do not number or indent headings, the 
user cannot distinguish deep layers of nesting. (NeoVision uses point size and font 
styles italics or underline to distinguish one level of heading from another.) 

Lists 
NeoVision applies Microsoft conventions for lists, rather than the guidelines in Chicago.  

Punctuation and Capitalization 
When you include a list within a paragraph, separate each item with a comma. A comma 
should precede the conjunction (and, or). Examples: 
You can create a grid, mosaic, bar, Hotspots, or tree display. 

Notice that the display types in the preceding example begin with a lowercase letter, with 
the exception of registered name Hotspots.  

To introduce the list, separate the introductory phrase from the list with a colon. The 
following examples use a colon and follow special rules for init-caps.  
Select the type of display from the Type drop-down list: Grid, Mosaic, Bar, Hotspots, or 
Tree. 

The previous example starts each display type with an init-cap, as they are shown in the 
drop-down list of the Displays tab. Notice that the drop-down list names appear in 
Courier, but the commas between them are Arial. See Family Overrides, page 5. 

Each item in a vertical (bulleted or simple) list begins with an init-cap. 
Select the type of display from the Type drop-down list: 

§ Grid 

§ Mosaic 

§ Bar 

§ Hotspots 

§ Tree  

In a bullet or simple list, end each entry with a period if one of the following is true: 

§ Individual entries are complete sentences. 

§ Each entry makes the introductory fragment a complete sentence. 

Use parallel structure for each entry. Example: 

Incorrect: 
This chapter describes: 

§ Connecting to a database 

§ The Database tab 

Correct: 
This chapter describes how to: 

§ Connect to a database. 

§ Use the Editor Database tab.  

Do not mix sentence fragments and complete sentences at the list item level. You can 
follow a fragment with complete sentences if you separate the fragment by a line feed: 
The Editor includes the following tabbed input forms: 
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§ Datafeed 

Use the Datafeed tab to specify which fields the Heatmap receives from a real-time data 
source.  

§ Database 

Use the Database tab to specify which fields the Heatmap can access from a relational 
database. 

Constraints 
Limit lists to two levels of nesting. 

Limit the number of items to 9 primary (level 1) items. If a procedure requires more than 
9 steps, split it into modular procedures. In the following example, each underlined, blue 
link leads to a subordinate procedure. 
To complete the Displays tab: 

1 Select or insert a display name. 

2 Choose one of the following display types and complete the formatting specific to that type.  

§ Grid 

§ Mosaic 

§ Hotspots 

3 Click Apply. 

Styles 
Always apply automated numbering and bullet list formatting. Do not manually type in 
numbers. The automated method updates numbers as add and delete items.  

§ Use the paragraph style in the NeoVision template for bullet and number list levels 1 
and 2.  

For example, the help system provides styles bullet and bullet1, number1 and 
number2.  

Because each NeoVision template depends on the authoring tool default template 
names, paragraph style name is tool-specific.  See the Template section in this Style 
Guide for style template specifics.   

§ If authoring in HTML, use nested levels of <OL> and <UL>.  

Use character bullets, not bitmap images. 

Correct:  
§ Item one 

Incorrect: 
  Item one 

For number lists, the styles assign numbers and lowercase letters.   
1  Step one 

   a  Substep one 
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Phrasing and Word Selection 
Goals: 

§ Geographically-independent vocabulary 

§ Reduced reading time  

§ Rapid comprehension 

§ Immediate – specific to a task-completion or problem-resolution 

§ Standard, universal, recognizable terminology 

§ Reduced document / file size 

§ Minimum translation cost 

§ Proper, formal business usage of the base language 

Standard Terms 
Refer to the Microsoft Manual of Style for Technical Publications to ensure industry-
standard phrasing regarding a software interface. The following guidelines from 
Microsoft are particularly pertinent to NeoVision interface documentation. 

§ Never follow a mouse action (click, right-click) with the word on.  

Correct: Click the cell to drill down to a detail display. 

Incorrect: Click on the cell to ...  

Note: You can use click in where the area to click is large. (Click in the window to make 
it active.) 

§ Hyphenate two-word verbs (right-click a cell) and two-word adjectives (drill-down 
display, real-time datafeed, real-time-data vendor). 

Notes:  

• You do not hyphenate drill down when drill is the verb and down an adverb: 
You can drill down to a child, or detail, display. Click a cell to access the drill-down 
details. 

• Right Click Menu applies only to the field label on the Displays tab of the Editor. 
In every other context, use right-click menu, or, preferably, cell or group menu. 

• When real is the adjective and time, a noun, do not hyphenate: 
The datafeed vendor sends information in real time. Use the Datafeed tab to describe the 
real-time information that populates the Heatmap. 

Constraints on Vocabulary 
Avoid synonyms. Repeat terms, keeping vocabulary within a small range of terms. 
Persons of non-American background use our products. In time, we might want to 
translate our documentation to another language. Translation is billed on a per-unique-
word basis. 

Sentence Structure  
To keep your content interesting and flowing, despite limited vocabulary, vary sentence 
structure.  Too many noun-verb sentences can lose the reader’s attention. 
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Interesting:  
To alternate among displays, use Select > Displays in the menu bar.  
Use the Displays tab to design ….  

Not interesting:  
The Displays tab provides …….  
The Select > Displays menu enables you to alternate among displays. 

Conciseness 
Keep sentences concise. Use present tense. Avoid the following unnecessary words and 
phrases: 

§ once  

§ have 

§ button   

Incorrect: Once you have selected a file, click the Open button. 

Correct: Click the file name and click Open. 

Precise Terms 
§ Use might rather than may to discuss possibilities. 

§ Use enables rather than allows.  

May and allow imply permission.  

§ Use can rather than might to discuss available features and options. 

§ Avoid wish. In the rare case that you need to indicate desire, use want.  

Incorrect: You may want to change the font size if you wish to reduce the size or the display. 

Correct: If you reduce the size of the display window, reduce the label font size. 

Verb Forms 
Never make a two-word verb into a contraction. In addition to sounding colloquial, 
contractions signal a negative statement or a unnecessary complex verb tense. 

Incorrect: Heatmaps Express won’t (can’t) save changes. 

Correct: Heatmaps Express does not enable you to save changes. To save, upgrade to 
Heatmaps Pro. 
Better: To save your Heatmap changes, upgrade to Heatmaps Pro. (Avoids the negative 
statement.) 

Use simple, present tense. 

Incorrect: 
 If you had selected File > Save As, the Viewer would’ve displayed a dialog …  

 After you select File > Save As, the Viewer will open a display a dialog… 

Correct: 
Select File > Save As, which displays the Save As dialog. 

Avoid the verb to be and use active tense whenever possible. 

Abbreviated Phrases 
§ Use and so forth to extend a list. Never use the abbreviation etc. 
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§ Use For example. Never use e.g. or EG or E.G. 

§ Avoid IE, i.e., or I.E. In addition to applying abbreviations, these terms introduce a 
redundancy.  

Avoid the phrase In other words. If you need to restate an idea for clarity, use the 
clearer form and delete the preceding vague form.  

If text does not clearly convey an idea, provide an example or figure to amplify. 
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Part II: Guidelines for Authoring Online Help 
This section address the conventions for hypertext information that the user views on a 
monitor. The guidelines in Part II describe NeoVision conventions specific to the 
ForeHelp product and therefore facilitate help file maintenance and update.  

In addition to this Guide, refer to books, periodicals, and professional organizations that 
discuss usability issues in the delivery of hypermedia.  

The following resources are available from Amazon.com or Fatbrain.com: 

Walker, J. and Taylor, T., The Columbia Guide to Online Style  

Sammons, M., The Internet Writer's Handbook   

Hackos, J.,  Standards for Online Communication: Publishing Information for the 
Internet/World Wide Web/Help Systems/Corporate Intranets  

The following seminal reference available from Amazon.com:  

Horton, P., Designing and Writing Online Documentation: Hypermedia for Self- 
Supporting Products, 2nd Edition 

The following URL lists resources for online help usability: 
http://www.berkeley.edu/standards/design.resources.html 

Naming Conventions 
Use names that help you categorize and locate resources in the help system. This 
section imposes guidelines for the following names: 

§ Figure files 

§ Related Topics (rto) Lists and associated hidden keywords 

§ Context strings for topics 

§ Topic names in banner and Contents List 

Figures 
Save all figures in gif format with the file extension .gif. 

Prefix gif filenames with the identifier e_ for editor or v_ for viewer. As the second part of 
the filename, use a category that helps locate the gif in the authoring tool insert-picture 
file browser.  

For example, the following filenames indicate screen captures that show an Editor tab.  

§ e_con_tab.gif. would contain the dialog view that you need for a Connections-tab 
overview topic, such as Using the Connections Tab. 

§ e_con_tab_datafeed.gif contains a screen capture from a datafeed-connection 
setup. Similarly, e_con_tab_database.gif, e_con_tab_dbchain.gif, and so 
forth, each show the setup for a particular type of connection. 

 

Topic Titles 
Use gerunds to start topic titles for procedures. Use the same verb for every similar 
topic. For example, all Editor tab top-level topics are entitled Using the ____ Tab. The 
following lists show the preferred verbs for title gerunds: 

Viewer examples: 

http://www.berkeley.edu/standards/design.resources.html
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Viewing a Page Display 

Modifying End Points 

Setting Display Options 

Editor examples: 
Using the Datafeed Tab 

Specifying Color-List Values 

Defining a DB Chain Connection 

Do not use gerunds in definition or concept topics. Examples, the following topics are all 
linked to the glossary. Some also appear in the Contents List: 
Built-in Functions 

Built-in Variables 

Color Buttons  

Colormaps 

Datafeed 

End Points 

Hotspots Display 

User-Specified Variable 

Try to avoid questions ( what, where, how, when in topic titles).  

Context Strings  
When adding or editing a topic, uncheck Context String from the Copy Title To area of 
the Topic Properties dialog. (Figure 1). The context string will rarely match the title. 
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Figure 1: Topic Properties 

 
Start context strings with the category that indicates its major subject. End each with a V 
(for viewer) or e (for editor). Examples:  
pagedisplay_viewing_v  

pagedisplay_configuring_v 

pagedisplay_defining_e 

colormap_color _list 

colormap_two_color 

colormap_def_v 

colormaps_tab_e 

Using a standard approach to context strings helps: 

§ Automate jumps 

When you insert a jump, ForeHelp scans both topic titles and topic context strings for 
a close match to the highlighted phrase that will cause the jump. 

§ Overwrite Imported topics, even if the titles differ  

§ Locate topics in a sorted contents list 

§ Edit similar topics in different projects 

§ Determine relationships among topics 
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Keywords 
When you create or edit a topic, uncheck Keywords from the Copy Title to area of the 
Topic Properties dialog (Figure 1, page 17.). Never use full sentences or gerunds or 
topic titles as keywords. 

Restrict keywords to a word or two-word phrase. Each keyword you add appears in the 
alphabetic Index list of a help system.  Use the same type of keywords that you would 
index entries in a printed, sequential book. You can create subordinate keywords if you 
prefer two-level indexes (Figure 2). 

Figure 2: Two-level keyword 

 
If you feel an index should contain synonyms, make one main keyword, and make the 
synonyms aliases of the keyword (Figure 3). 

Figure 3: Keyword alias 

 

Related Topics Lists 
To avoid duplicating related topics (rto) lists, try to assign the same rto to every topic 
listed under a major category (top-level book) in the contents list. 

For example, the following sample of general headings might apply to Heatmaps help: 
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Book Topics rto name 

Introduction Using the Help System 

What Are Heatmaps ? 

Advantages of Heatmap Analyses 

Heatmaps Viewer And Editor 

Contacting NeoVision Technical Support 

rtoIntroHeatmaps 

Viewing 
Heatmaps 

Opening the Heatmaps Viewer 

Navigating Between Displays 

Parts of the Viewer Window 

Viewer Menu Bar and Shortcuts 

 

Managing Windows 

Saving the Heatmap in the Viewer 

rtovIntroViewer 

 Using Heatmaps Displays 

Types of Heatmap Graphical Displays 

rtovDisplays 

Specifying 
Display 
Options 

Initial Display 

Hiding and Showing Display Components 

Displaying Cells, Groups, or Group Labels 

Changing Font Sizes 

Mosaic Display Options 

Bar Display Options 

Hotspots Display Options 

rtovDisplayOptions 

Seeing More 
Information 

 

Viewing Popup Displays rtovPopups 

 Viewing Page Displays 

Configuring the Page Display Layout 

Displaying Multiple Instruments in a Page 
Display 

Exporting Page Displays 

rtovPageDisplay 

 Child Display 

Viewing Cell and Group Menus 

rtovDisplays 

rtovRightClickMenu 

Using 
Analyses 
Formulas 

 

Color Buttons 

Selecting Analyses 

Displaying an Analysis Formula 

Setting Button Properties 

Formula Variables 

Setting Button Variables 

Using Relative Values or Colors 

rtovButton 

 

 

 

 

 

rtovDisplaysOptions 
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Book Topics rto name 

Using Alerts 

 

Alerts 

Viewing the Alert Log 

Setting Alert Thresholds 

Disabling or Enabling Alerts 

Resetting Alerts 

rtovAlerts 

Using 
Colormaps 

 

Colormaps 

Highlighting Colormapped Cells 

Modifying End Points 

rtovColormaps 

Rearranging 
Contents 

Loading Contents 

Grouping Cells 

Sorting Cells 

rtovDisplayOptions 

Working With 
Cells 

Finding Cells by Symbol 

Editing Cells 

rtovDisplayOptions 

none 

   

Editing Heatmaps Using the Heatmaps Editor 

Opening the Heatmaps Editor 

Editor Components 

Component Usage Report 

Importing Heatmap Components 

Using the Operand List 

Editor Menu Bar and Shortcuts 

 

Saving the Heatmap Editor Configuration 

rtoeIntroEditor 

Defining 
Datafeed 
Contents 

Datafeeds 

Contents And Groups 

Using the Datafeed Tab 

Selecting or Creating a Datafeed Content 

Defining a Content Grid Layout 

Configuring the Primary Column 

Adding and Arranging Groups 

Table Shortcuts 

Inserting Group Columns 

Deleting Group Columns 

Inserting Group Cells 

Deleting Group Cells 

Setting a Reference Cell in the Editor 

rtoeDatafeed 



Technical Publications Manual of Style  Part I: General Guidelines  

 

Book Topics rto name 

Defining a 
Database 
Template 

 

Database Templates 

Using the Editor Database Login 

Using the Database Tab 

Selecting or Creating a Database Template 

Creating a Select Type Template 

Parts of a Select Type Template 

Specifying Select Rows 

Specifying From Tables 

Creating a Procedure Template 

Specifying a Hierarchy 

Testing Database Templates 

rtoeDatabase 

 Specifying a Where Clause rtoeWhereClause 

Defining 
Colormaps 

 

Colormaps 

Colormap Types 

Colormap Color Schemes 

Using the Colormaps Tab 

rtoeColormap 

Formulas 

 

Formulas 

Avoiding Ambiguous References 

Built-in Functions 

Formula Language 

Formula Examples 

Testing a Formula 

Foreign Functions 

Installing C Foreign Functions 

Installing Java Foreign Functions 

rtoeFormula 

Defining 
Variables, 
Macros, and 
Buttons 
 

Variables 

Variable Types 

Built-in Variables 

Using the Variables Tab 

Macros 

Macro Examples 

Using the Macros Tab 

Color Buttons 

Using the Buttons Tab 

Advanced Variable and Macro Usage 

rtoeVariable 

 

 

 

rtoeMacro 

 

 

rtoeButton 
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Book Topics rto name 

Defining 
Connections 
 

Connections 

Using the Connections Tab 

Selecting or Creating a Connection 

Selecting the Connection Type 

Defining a Datafeed Connection 

Defining a Database Connection 

Defining a DB Chain Connection 

Defining an Index Chain Connection 

Defining an Option Chain Connection 

Displays Allowed by Connection Type 

rtoeConnection 

Defining 
Displays 

 

Displays 

Display Components 

Using the Displays Tab 

Selecting or Creating a Display 

Defining a Popup Display 

Defining a Page Display 

Defining a Right Click Menu 

Defining Child Displays 

rtoeDisplay 

The above table shows only the rto that names the Related Topics button in each topic. 
It does not also show the rto’s on which each topic is listed as a related item. To find out 
all the related topics names, print a Keywords report in ForeHelp.  

Notice that the rto names follow the same general conventions as the gif file names 
except they start with the letters rto, as follows: rto    e|v    book 

Using the Related Topics Wizard 
Never allow ForeHelp to generate the rto names automatically. When you use the 
Related Topics Wizard, overwrite the ForeHelp default name with one that has the 
above format. Always use enough letters to convey the meaning of the rto. Typical 
ForeHelp rto names, such as rtovUsingADisp and rtovUsingingADis2, do not 
convey meaning and are hard to maintain. 

The Wizard assigns a keyword with the prefix A: to each related topics list. Make sure 
the A keyword for the related topics list matches the rto name. You cannot edit a related-
topics keyword in the Wizard, but you can change it, if necessary, in the Project > 
Keywords… dialog. ForeHelp uses the A keywords to indicate a topic that is listed in 
another topic’s Related Topic list. 

If the Related Topics button appears at the top of a project or does not have the words 
“Related Topics” on it, return to the Wizard and fix the button as follows: 

1. Put your cursor to the left of the Related Topics button and right-click.  

2. Select Edit the Related Topics List. 
3. Click Next in the Wizard until you reach the screens in Figure 4 and Figure 5. Fill 

in the Wizard dialogs as the figures show. 
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Figure 4: Related Topics button format 

 
Figure 5: Related Topics location 

 

Browse Sequences 
To facilitate separating Lite (Viewer only) help from Pro (Viewer and Editor help), 
NeoVision Heatmaps help contains four separate browse sequences (Figure 6): 
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§ Editbrowseseq contains the items from the contents list book entitled Editing 
Heatmaps 

§ Mainbrowseseq contains the items from the contents list book entitled Introduction. 

§ Techrefbrowseseq contains the items from the contents list book entitled Technical 
Appendix and the topic named Glossary.. 

§ Viewerbrowseseq contains the items from the contents list book entitled Viewing 
Heatmaps. 

Figure 6: Creating a browse sequence 

 
To create a browse sequence: 

1. Select Project > Browse Sequences 

2. Below the All Topics list (left container of the dialog, as Figure 6 shows), click 
Contents so that you see the hierarchical content list rather than an alphabetic list of 
topic names. 

3. Click the + sign to expand one book. Figure 6 shows the Introduction book 
expanded. 

4. Select all the topics in that book. 

5. In the right-hand Sequences list, click the name of the browse sequence that this 
book belongs in. 

6. Click Add. 

7. Repeat steps 3 to 6 for each, separate browse sequence.  

 


