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Heatmaps for Brokerage Management (BrokerMaps) 
Imagine a trading manager who can instantly recognize: 

 Opportunities compatible with client portfolios 

 Risks endangering client portfolios 

 Individual broker performance 

 Hotspots of activity in global markets 

This manager can alert the specific broker responsible for specific portfolios 
about opportunities and risks. This manager can spot brokers who need 
additional training and find high-performance traders to mentor them. This 
manager can vigilently keep his organization profitable.  

Imagine a broker who can:instantly: 

 Organize client accounts by investment balance, profit, loss, value at risk 

 Organize client positions by industry sector, market risk, credit risk, or trends 

 Compare client positions with up-to-date trade prices, activity since purchase, 
and other real-time information from online financial-data services 

This broker will lead his team in profits for clients. 

Imagine an investor who can, on demand: 

 Access a variety of graphed models of personal account positions via 
personal computer or broker terminal 

 Apply favorite analytics on-the-fly for visual “what if” analysis 

 Compare a personal portfolio with up-to-date global market activity 

 Request secure, confirmed trades through a preferred broker with the click of 
a mouse on a graph. 

 Watch the performance of the brokerage as whole  

This client benefits from both online trading and long-term professional guidance. 

Your brokerage can obtain all these benefits in one, easy to use, software 
application, called Heatmaps. We invite you to experience its power today. 

Manager View  
When you first launch the Heatmaps for Brokers you see a trading manager’s 
view. Each of the 100 small squares, called cells, identifies a top-performance 
vehicle owned by at least one client of the brokerage. The initial view shows 
values for dollar position across the brokerage. The bluer the cell, the greater 
stake your clients have in the vehicle that the cell represents.  
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In Figure 1, we click a button on the right of the screen to choose a different 
analytic for value comparison. The new analytic shows values for average gain 
(blue cells) or loss (red cells) across all client portfolios. Because the cells are 
sorted by dollar position, they appear in order of relative position. You can 
compare the commitment in total dollars of your clients against the relative gain 
or loss in value of investment dollars during the current trading session. 

Figure 1: Top 100 client choices 

 
Now you know how your clients fair on average. Should they buy, sell, or hedge 
on any of these vehicles?  

Refer to Figure 2. Click the Dollar Gain/Loss (1M) button to see the past 
month’s trends in price across all investments for that vehicle in the market place.  
In Figure 2, we changed the sort order to show relative performance, from loss to 
gain, across the brokerage. To change the sort order, click the Tools menu, then 
click Sort Ascending By or Sort Descending By. In Figure 2, we chose Sort 
Descending By and then chose Average Gain / Loss (%).   

By sorting on one analytic and choosing cell color according to a different 
analytic, we can add a dimension to the information the graphic gives us. Notice 
how much you learn without a textual listing of figures. Everything is arranged by 
color and order. 

We noticed that LVLT is red (decreasing in value) both in your client portfolios 
(Figure 1) and on the open market.(Figure 2). For a synopsis, we view the yellow 
popup details for LVLT. To view the popup details for any vehicle in a display, 
hold your mouse over the cell.  
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Figure 2: One-month global trend 

 
A trading manager next views all the accounts that have some investment in 
LVLT in case the manager wants to alert affected brokers to offer an alternative 
investment to their individual investors. To view all the clients who own LVLT, 
click the mouse on the LVLT cell. Figure 3 shows the results, sorted by account 
balance and colored by account returns.  

Because the name of the broker responsible for each group of accounts appears 
at the left, the display shows that the largest (left-most) account managed by 
broker Charlesworth has suffered significantly poor (red) returns from LVLT. 
Again, we hold the mouse over the account cell to see more details.   
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Figure 3: All Clients with LVLT positions 

 
At a glance, you, as manager also see that broker Charlesworth has several 
accounts suffering losses from LVLT.  To view overall performance by the broker,  
select a display that provides a comparison of agent performance. Click the 
Select menu, click Displays, then choose either the All Client Accounts 
Heatmap (a grid, Figure 4) or All Client Accounts Mosaic (Figure 6).  

Figure 4 sorts accounts by balance and colors the cells by return value. In Figure 
4, you readily see from the proportion of red cells in their groups, that both broker 
Charlesworth and broker Berry manage many accounts that have diminishing 
returns. In contrast, broker Adams accounts all experience profitable returns. You 
might want to ask broker Adams to help broker Charlesworth and Berry assess 
their account portfolios to redistribute their clients investments. 

In Figure 5, we reverse the sort order and analytic button and notice that broker 
Berry’s largest (bluest) account appears in the lowest (right-most) position of 
return.  You might counsel broker Berry to quickly improve the profitability of the 
portfolio belonging to account 10379 before you lose the account to another 
brokerage. 
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Figure 4: Grid comparison of returns sorted by balance 

 

Figure 5:  Balance sorted by return 
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Using the mosaic (Figure 6), you can quickly compare balances with returns by 
broker. Square size varies according to balance. Thus, large, red cells indicate 
clients with high balances that need repair. Notice that brokers appear to have 
either many losing accounts or all profitable accounts. To find out which broker’s 
group is primarily red (losing money), click the View menu, then click Force 
Group Labels. Each broker’s name appears over the corresponding group of 
cells. To compare aggregate return by broker, click View, then Groups. 

Figure 6: Mosaic comparison among brokers 

 

Broker Views 
In this section, you play the part of a broker, in this case, broker Adams. In your 
broker role, you can view a grid summarizing all of the accounts that you 
manage: 

1.  From the initial display, Top 100 Client Positions (Figure 1, page 2), click 
the Select menu, click Displays, then choose All Client Accounts Heatmap 
(Figure 4, page 5) 

2. Put your mouse over a cell in your group and click the right button to display 
the cell menu. Click This Broker’s Accounts Heatmap.  See the example in  
Figure 7. 
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Figure 7: Cell menu for an account in broker Adams' group 

 
Figure 8 shows broker Adams accounts sorted by balance and color-coded to 
indicate comparative returns. To your credit, all your accounts experience some 
gain. The display contains no negative returns. However, as broker Adams, you 
might want to analyze the light blue and white cells that appear in the top two 
rows, because these indicate large balances that realizing poor returns. 

Figure 8: Broker Adams account summary 

 
To analyze a particular account, click on the cell that represents the account. For 
example, if you click on the white cell depicting account A10121, you see a 
breakout of account A10121’s investments, as in Figure 9. 
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Figure 9: Single account analysis 

 
Broker Adams arranges Mr. Henderson’s holdings from highest to lowest dollar 
position in each industry sector. The Tools menu provides Group By and Sort 
Ascending/Descending By options to help you arrange a view to emphasize 
those factors you want to analyze.  

Because the market is fluctuating day to day, particularly in the Communications 
sector, broker Adams chooses the 1M Chg (%) button to see the longer-range 
trend in trade price over the past month.  Other buttons, such as 3M Chg (%) 
(three-month change) and P/E Ratio yield similar color relationships among the 
investments.  

Total P & L (Figure 10) indicates that Mr. Henderson’s portfolio has too much 
loss in the non-cyclical consumer investments, despite the stable performance 
over the last month. 

Figure 10: Account long-term profit and loss 
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 To fine-tune the analysis, broker Adams clicks Select and Display to choose the 
Hotspots® view of this account. You can see, in Figure 11, that the broker can 
simultaneously see four factors regarding account A10121: 

  Spot size indicates relative dollar position in each investment vehicle.  

 The vertical (Y) axis places losing vehicles below profitable vehicles. 

 The horizontal (X) axis arranges vehicles from low to high according to 
3M Chg (%), the change in price since three months ago.  

 Color indicates relative strength over a fourteen-day period. To calculate 
strength (RSI), the data source divides average rising closing prices by 
average declining closing prices for the vehicle over the last fourteen days. 

All the spots cluster around the middle of the graph, which means they hardly 
fluctuated over the three-month period.. Notice that a large, yellow spot appears 
at the bottom (lowest P&L). Large spot means big investment, yellow color 
means medium strength.  

Recall that you hold you mouse over a cell to see the popup details. Agent 
Adams holds the mouse over that big yellow, losing spot to identify the issuing 
company and to obtain exact dollar amounts. The stock does not have sufficient 
relative strength to justify a wait-and-see attitude.  Instead, the broker checks the 
recommended buys published regularly by the brokerage. 

Figure 11: Four-dimensional Hotspots display 

 
The broker leaves the client window open, and opens a new window to see 
recommendations. In the File menu, click New Window. 
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In the second window, broker Adams clicks Select and Display, then chooses 
Recommendations Heatmap.  Normally the recommendations shows separate 
groups to distinguish growth vehicles from income vehicles. Anxious for a buy 
suggestion, the broker clicks Tools, then Group By, then Rating, which results 
in Figure 12. Broker Adams sorts the vehicle cells by volume and color-codes 
them by relative strength.  

Figure 12: Recommended buys 

  

In the Heatmaps window that shows the account Hotspots graph, broker Adams 
clicks Go and Back to return to the grid view in Figure 9 on page 8. In the grid, 
you can see all the vehicles clearly identified by ticker symbol. By comparing the 
account grid with the recommendations grid, you can look in the strong-buy 
group for strong (green) investments that the account does not already own. 
Remember to hold the mouse over any strong buy cells that look promising to 
see more details to indicate why your company recommends those cells as 
strong buys. 

We hope you enjoyed your experience with at-a-glance broker and account 
analysis. If client Henderson has internet service, he can see the views of his 
own accounts in Figure 9, Figure 10, and Figure 11, as well as the brokerage 
recommendations shown in Figure 12.  

Summary  
Heatmaps visualization provides the following benefits to your brokerage: 

 Proactive management  

 Rapid reaction to clients 
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 Enhanced content and depth. 

 Quickly answers the question, “How are my clients doing today?” 
 Unified application set -- Client Inquiry, Gain/Loss, Holdings across Book  

 Productivity aids: 

 Single page vs. many 

 Integrated applications 

 Information and service aids: 

 Performance data 

 Performance over time data 

 Quantitative data 

Figure 13: Your account is one mouse click away 
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